Join Today
Resultados 1 al 3 de 3

Compartir

  • Enviar a Twitter
  • Enviar a Facebook
  • Enviar a Google
  • Enviar a Digg
  • Enviar a Reddit
  •  
    1. #1
      UltraCreativo 2009 Avatar de nemesis
      Fecha de ingreso
      21 feb, 07
      Mensajes
      1,156
      Reputación
      2046
      Mentioned
      0 Post(s)
      Tagged
      0 Thread(s)

      Default Dock Icon Problemas con "../" en los Subdominios

      Hola muchachos, les presento mi problema para ver a quien se le ocurre algo :idea:

      Si colocamos "../" al inicio de un path hace que la búsqueda sea en un directorio atras.

      Ejemplo:


      Todo perfecto hasta acá, el problema viene cuando uso subdominios y no consigue conectar con el destino.

      Alguien conoce una solución que no sea cambiar las rutas?.
      Gracias :exclaim:

      Saludos.
      Última edición por nemesis; 25/03/2011 a las 01:02

    2. #2
      The Architect Avatar de Snipervzln
      Fecha de ingreso
      21 feb, 07
      Ubicación
      Caracas, Venezuela
      Mensajes
      6,952
      Reputación
      17194
      Mentioned
      1 Post(s)
      Tagged
      0 Thread(s)

      Re: Problemas con "../" en los Subdominios

      Nemesis, cuando configuras un subdominio la carpeta donde este reside se convierte en la raiz, por consiguiente no puedes ir un directorio atras porque simplemente no existe.

      Ahora bien, si estas trabajando en html y tu problema de rutas se refiere solo a una carpeta puedes usar la propiedad base tag para definir la url base para las rutas relativas dentro del documento. Esta base debe ser una url absoluta.

      Por ejemplo:

      [html]

      <head>
      <base href="http://www.dominio.com/subdominio/" />
      </head>

      <body>
      <img src="../imagenes/img.jpg" />
      </body>

      [/html]

      Se asume que la carpeta que contiene las imagenes esta en "http://www.dominio.com/imagenes/"

      Esta es la forma mas sencilla de hacerlo si estas en html. Si el llamado a la ruta se hiciera desde javascript o php la vaina se pone mas peluda y tendrias que usar symlinks o mod_rewrite via htaccess.


    3. #3
      UltraCreativo 2009 Avatar de nemesis
      Fecha de ingreso
      21 feb, 07
      Mensajes
      1,156
      Reputación
      2046
      Mentioned
      0 Post(s)
      Tagged
      0 Thread(s)

      Re: Problemas con "../" en los Subdominios

      Bien!. Funciona muy buen, grcias Sniper.



      Saludos.